版权声明

版权所有 © 深圳市海思半导体有限公司2012。保留一切权利。

非经本公司书面许可，任何单位和个人不得擅自摘抄、复制本文件内容的部分或全部，并不得以任何形式传播。

商标声明

和其他海思商标均为深圳市海思半导体有限公司的商标。 本文档提及的其他所有商标或注册商标，由各自的所有人拥有。

注意

于产品版本升级或其他原因，本文档内容会不定期进行更新。除非另有约定，本文档仅作为使用指导，本文档中的所有陈述、信息和建议不构成任何明示或暗示的担保。

海思专有和保密信息
版权所有 © 深圳市海思半导体有限公司


欢迎使用IDT映像下载工具 帮助

本帮助包括以下内容：

  • 系统简介
    本章介绍IDT的功能、运行环境和软硬件要求。
  • IDT下载环境搭建
    本章详细介绍IDT的软件安装，以及运行IDT下载软件前的配置。
  • 映像合并工具使用
    本章介绍映像合并工具（Merge Tool）的使用。
  • 界面介绍
    本章详细介绍IDT PC端操作界面。
  • IDT下载工具使用
    本章介绍IDT下载工具的使用方法。
  • IDT下载工具在实验室的使用方式
    本章介绍IDT下载工具在实验室的具体使用方式和步骤。
  • 特性更新记录
    本章介绍IDT不同版本中的特性更新说明。
  • 常见故障处理
    本章介绍常见故障的原因分析及处理方法。
  • 错误列表
    本章提供使用IDT工具下载失败时返回的错误类型查询。
  • 缩略语


系统简介

本章介绍IDT的功能、运行环境和软硬件要求。

  • 软件介绍
  • 运行环境
  • 配置要求
父主题： 欢迎使用IDT映像下载工具 帮助


软件介绍

IDT（Image Download Tool）映像下载工具、MergeTool映像合并工具和USB Map工具是深圳市海思半导体有限公司K3V200R001平台的配套工具软件，主要用于开发平台或参考设计的映像文件下载（ImageDownload）和映像文件合并（ImageMerge）。

IDT和MergeTool不仅可以用作K3V200R001平台终端生产线映像下载，也可以用作实验室中批量映像下载和映像合并。其功能描述如表1所示。

表1 功能描述
名称 | 描述
IDT | 映像下载 将合并好的映像文件烧写至1个或者多个（最多8个）终端设备中。
Merge Tool | 映像合并 将相关映像和数据打包成映像文件，供IDT下载。
USB Map | USB映射 搭建产线加载环境，使USB端口与手机建立固定映射关系。
父主题： 系统简介


运行环境

Merge Tool

MergeTool是一个Win32控制台程序，在PC命令行下运行。

IDT

IDT软件运行在PC机上，PC机通过USB接口进行连接，如图1所示。

图1 镜像加载运行环境图
父主题： 系统简介


配置要求

软件要求

操作系统：Windows XP、WIN7或Windows Server

驱动程序：Android Phone 驱动、USB虚拟串口VCOM驱动

合并工具：MergeTool

下载工具：IDT

硬件要求

1台PC机：CPU主频 2.0GHz、 内存空间 1GB、硬盘空间 10GB（最低配置要求）

1台USB HUB

8根USB连接线

8台终端设备

父主题： 系统简介


IDT下载环境搭建

本章详细介绍IDT的软件安装，以及运行IDT下载软件前的配置。

  • 准备
  • USB MAP配置
  • 查询USB虚拟串口和ADB设备注册信息
父主题： 欢迎使用IDT映像下载工具 帮助


准备

软硬件配置

请确认电脑的软硬件配置满足配置要求中的描述。

安装USB驱动

请参考《USB驱动安装指导》安装USB虚拟串口和USB ADB设备驱动。

父主题： IDT下载环境搭建


USB MAP配置

USB MAP配置步骤如下：

  1. 准备8个USB插口，标记为1～8。
  2. 根据实际应用场景，修改Usbloader的启动地址（默认是F8000000），如图1所示。

    图1 设置Usbloader的启动地址

    当Usbloader地址输入格式错误，则会弹出警示对话框，提示拔下单板后改成正确的Usbloader启动地址，如图2所示。

    图2 Usbloader地址输入格式错误

  3. 导入可做为Usbloader的img文件，如图3所示。

    图3 导入Usbloader的K3平台的fastboot.img文件

  4. 将终端设备插入一个USB接口（按从1到8的顺序），等待USB虚拟串口和ADB设备先后都出现，如图4和图5所示。

    • 如果两个设备都出现，转到步骤6；
    • 如果任意一个设备未出现，转到步骤5。

    注意：系统若未安装USB驱动，请先安装驱动。

    图4 出现虚拟串口标识
    图5 出现ADB设备标识

  5. 等待一段时间(15s)后，USB虚拟串口和ADB设备ID无法正常出现，则从该USB拔下单板，点击“Skip”按钮。软件会标记此USB接口有问题，如图6所示。

    图6 标记出现故障的USB接口

  6. 重复步骤4，直至8个虚拟串口和ADB设备数据都被记录（如有错误的端口也应被标记），如图7所示。

    图7 接口数据记录

  7. 点击“Done”按钮把USB映射信息写入系统注册表，完成整个配置，退出程序。

    ----结束

父主题： IDT下载环境搭建


查询USB虚拟串口和ADB设备注册信息

查询USB虚拟串口和ADB接口注册信息的步骤如下：

  1. 在Windows系统的“ 开始-->运行”中输入“regedit”打开注册表。
  2. 进入HKEY_LOCAL_MACHINE\SOFTWARE\Hisilicon\IDT\ENUMERATIONS，查看USB虚拟串口和ADB 设备注册信息是否成功，如图1所示。
图1 USB虚拟串口和ADB接口注册信息

----结束

父主题： IDT下载环境搭建


映像合并工具使用

本章介绍映像合并工具（Merge Tool）的使用。

说明：

映像合并工具用于合成可供IDT下载的映像文件。若已有映像文件，可直接参考IDT下载工具使用。

  • 目的和准备
  • 操作步骤
父主题： 欢迎使用IDT映像下载工具 帮助


目的和准备

目的

将分区镜像文件合并为二进制镜像，供IDT工具下载使用。

准备

创建MergeImage目录。复制分区镜像文件、映像合并工具到此目录下。

注意：

目录路径请勿出现非英文字母字符。

父主题： 映像合并工具使用


操作步骤

进入MergeImage目录，输入命令行将各分区镜像文件打包生成一个文件。

命令格式

输入命令格式如下：

usage: mergetool [ <option> ] <command>

命令行的参数格式说明如下：

  • command
flash <partition> [ <filename> ]        //pack a partition file to a packet image file
  • option
-o <image filename>                        //specify a target image file name
-b <base_addr>                              //specify a custom start address
-h <hardware version>                    //specify hardware version
-s <image filename>                       //split a target image file to every custom file

举例说明

例如输入以下代码，具体显示如图1所示。

MergeTool.exe -o TestImage.bin flash usbloader usbloader.img flash fastboot fastboot.img flash boot boot.img flash userdata userdata.img flash system system.img
flash recovery recovery.img flash ptable ptable.img
图1 映像合并
父主题： 映像合并工具使用


界面介绍

本章详细介绍IDT PC端操作界面。

  • 主界面
  • 菜单栏
  • 工具栏
  • Workspace窗口
  • 下载窗口
  • Output窗口
父主题： 欢迎使用IDT映像下载工具 帮助


主界面

IDT软件的操作主界面如图1所示。

图1 操作主界面

IDT主界面有为5个功能区，与图中编号对应关系如表1所示。

表1 IDT主界面区域功能简介
编号 | 功能区名称 | 功能简述
1 | 菜单栏 | 菜单栏按照功能组织各菜单项，包括：“File”、“Operation”、“View”和“Help”。
2 | 工具栏 | 通过IDT工具栏快捷按钮，可以完成IDT的基本操作。
3 | Workspace窗口 | USB下载端口操作区。
4 | 下载窗口 | IDT下载过程中，显示对应USB端口的下载信息和状态。
5 | Output窗口 | IDT运行信息输出。
父主题： 界面介绍


菜单栏

菜单栏主要包括以下4个功能菜单：

  • File菜单
  • Operation菜单
  • View菜单
  • Help菜单
父主题： 界面介绍


File菜单

File菜单界面如图1所示，菜单项描述如表1所示。

图1 File菜单
表1 File菜单项描述表
名称 | 功能
Exit | 退出程序。
父主题： 菜单栏


Operation菜单

Operation菜单界面如图1所示，菜单项描述如表1所示。

图1 Operation菜单
表1 Operation菜单项描述表
名称 | 功能
Start | 开始下载。
Stop | 停止下载。
Setting... | 映像下载相关配置。
父主题： 菜单栏


View菜单

View菜单实现在主界面中显示和关闭Toolbar、Workspace和Output窗口。

通过设置选项打勾激活此3个窗口：

  • 打勾：窗口已激活（在主界面中显示）
  • 不打勾：窗口未激活（取消在主界面显示）

默认情况下，3个窗口均处于激活状态，如图1所示。

图1 View菜单
父主题： 菜单栏


Help菜单

Help菜单界面如图1所示。菜单项描述如表1所示。

图1 Help菜单
表1 Help菜单项描述表
名称 | 功能
Index… | 打开IDT联机帮助文件。
About IDT… | 介绍软件版本及版权信息。
父主题： 菜单栏


工具栏

IDT工具栏如图1所示。各快捷按钮功能描述如表1所示。

图1 工具栏
表1 快捷按钮功能描述表
图标 | 功能
 | Start（开始下载）。
 | Stop（停止下载）。
 | Setting（映像下载相关配置）。
 | About（显示版本及版权信息）。
父主题： 界面介绍


Workspace窗口

Workspace窗口为树状结构显示，每一个子节点“USB n”（n=1～8）对应一个USB下载端口。

右键单击子节点会弹出日志查看选择菜单，如图1所示。菜单项功能描述如表1所示。

图1 Workspace窗口
表1 Workspace右键菜单项功能描述
名称 | 功能
Show Latest Log... | 查看对应USB端口最新的日志
Show All Log... | 查看对应USB端口所有的日志
父主题： 界面介绍


下载窗口

下载窗口界面有如下6种：

  • 未启动下载，如图1所示。
    图1 未启动下载
  • 等待终端设备连接，如图2所示。
    图2 等待终端设备连接
  • 下载中，如图3所示。
    图3 下载中
  • 下载成功，如图4所示。
    图4 下载成功
  • 下载失败，如图5所示。
    图5 下载失败
  • 下载停止，如图6所示。
    图6 下载停止
父主题： 界面介绍


Output窗口

Output窗口实现IDT运行信息输出（红色字体提示错误和告警信息），在用户使用工具的过程中提供参考帮助，如图1所示。

图1 Output窗口
父主题： 界面介绍


IDT下载工具使用

本章介绍IDT下载工具的使用方法。

  • 准备
  • 工具配置
  • 映像下载
父主题： 欢迎使用IDT映像下载工具 帮助


准备

确认是否有可下载的映像：

  • 若有需要下载的映像，请按映像下载中的步骤执行下载操作。
  • 若无需要下载的映像，请按映像合并工具使用中的步骤执行映像合并，提供可下载的映像。

父主题： IDT下载工具使用


工具配置

IDT启动后，需要先进行基础配置，具体步骤如下：

  1. 单击菜单栏“Operation->Setting...”，或者单击快捷键（如图1所示），启动配置流程。

    图1 Setting...快捷键

  2. 在弹出的“Password”对话框中输入密码（默认密码为：hisilicon），如图2所示。

    图2 Password对话框

  3. （可选）如需更改密码，单击“Change Password”进入更改密码对话框，如图3所示。

    图3 更改密码对话框

  4. 输入配置密码后，用户可以在弹出的“Download Setting”对话框中进行基础配置，如图4所示。其中各配置项描述如表1所示。

    图4 Download Setting对话框

表1 下载配置项描述
属性名 |  | 含义 | 备注
File Setting | DLL Model | 下载所使用的Model.dll路径。 | -
 | Image File | 映像文件路径。 | -
Window Setting | Horizontal Windows Number | 下载小窗口水平个数。 | 根据实际屏幕分辨率设定
 | Total windows Number | 下载小窗口总个数。 | 建议设定总个数与USB Map映射的端口数一致

----结束

父主题： IDT下载工具使用


映像下载

IDT下载工具使用步骤如下：

  1. 强制终端设备进入下载模式。请根据下载模式选择对应的步骤：

    • 升级方式下载：通过组合按键（具体按键请参照各产品设定说明），或者通过ADB命令（adb reboot bootloader）进入fastboot下载模式。
    • 片内方式下载：通过短接BOOT_MODE和GND强制进入加载模式（裸板首次加载不需要短接可直接进入加载模式），在PC上会罗列出所有USB 虚拟串口。

  2. 单击菜单栏“Operation->Start”，或者单击Start快捷键（如图1所示）启动下载。IDT工具会自动执行下载过程，如图2～图4所示。

    图1 Start快捷键
    图2 等待镜像文件载入内存
    图3 准备烧写
    图4 镜像下载中（4台终端设备同时连接上USB1～USB4）

  3. 等待下载完成。

    下载完成后，成功的界面如图5所示，下载失败的界面如图6所示。

    下载失败后，会出现FAIL提示，ERROR (XX)，其中XX表示错误号，具体含义请参见“错误列表”。
    图5 下载成功
    图6 下载失败

    ----结束

父主题： IDT下载工具使用


IDT下载工具在实验室的使用方式

本章介绍IDT下载工具在实验室的具体使用方式和步骤。

  • 使用说明
  • 使用步骤
父主题： 欢迎使用IDT映像下载工具 帮助


使用说明

在实验室中，一般只需要使用单一端口下载镜像。在此情况下，无需执行USB MAP进行虚拟串口号和ADB设备ID号的配置，可以直接使用IDT工具进行下载。

注意：

此方式只支持单一端口。

父主题： IDT下载工具在实验室的使用方式


使用步骤

在单个终端设备下载的应用场景中，需要将此设备强制进入下载模式。请根据下载模式选择对应的操作步骤：

  • 升级方式下载：通过组合按键（具体按键请参照各产品设定说明），或者通过ADB命令（adb reboot bootloader）进入fastboot下载模式。
  • 片内方式下载：通过短接BOOT_MODE和GND强制进入加载模式（裸板首次加载不需要短接可直接进入加载模式），在PC上会显示USB 虚拟串口。

此场景中，IDT只有USB1进行下载，使用步骤请参考“IDT下载工具使用“。

父主题： IDT下载工具在实验室的使用方式


特性更新记录

本章介绍IDT不同版本中的特性更新说明。

IDT不同版本中的特性更新说明如表1所示。

表1 特性更新记录

序号

版本

更新内容

1

Model K3V200 V1.0.0.02

  • 解决Stop按钮失效问题

2

Model K3V200 V1.0.0.03

  • 增加每次下载信息的LOG保存
  • 提高镜像下载速度，速度提高了60%
  • 屏蔽下载窗口Esc和Enter键退出功能

3

Model K3V200 V1.0.0.04

  • 更改下载窗口显示字体样式

4

IDT V1.0.0.02

  • 增加显示Model 版本号
  • 增加Loading image 提示框，防止IDT界面假死
  • 屏蔽Esc和Enter键退出功能

5

IDT V1.0.0.03

  • 增加菜单栏、工具栏、左边（Workspace）和下边（Output）窗口
  • 增加工具配置密码权限控制功能
  • 更改下载窗口数量为可配置（V1.0.0.02固定8个）
  • 删除Start/Stop按钮

6

IDT V1.0.0.04
  • 修正Model.dll卸载之后，镜像内存泄漏问题
  • 修正下载窗口在Stop之后，重新Start，拖动或者缩放窗口造成字体大小显示错误
  • 修正在更改密码窗口某些操作下造成工具死机问题
  • 增加Output窗口用红色字体显示错误和警告提示信息

父主题： 欢迎使用IDT映像下载工具 帮助


常见故障处理

本章介绍常见故障的原因分析及处理方法。

  • 终端设备连接IDT不启动下载
  • 虚拟串口下载完成之后不能进行ADB下载
  • ADB下载分区不存在或数据太大
父主题： 欢迎使用IDT映像下载工具 帮助


终端设备连接IDT不启动下载

现象描述

BOOT_MODE点短接，连接USB，启动IDT，IDT不进行任何下载。

原因分析

1.之前使用USB MAP映射的端口与当前使用的端口不一致。

2.USB虚拟串口1分钟之内没有连接操作会自动消失。

3.USB驱动未安装，或者安装版本不正确。

处理方法

【原因1解决方案】

  1. 在Windows系统的“ 开始-->运行”中输入“regedit”打开注册表。
  2. 进入HKEY_LOCAL_MACHINE\SOFTWARE\Hisilicon\IDT\ENUMERATIONS，删除所有键值，重新使用USB MAP工具（实验室下载不使用USB MAP工具），重启IDT工具。

    ----结束

【原因2解决方案】

重新插拔USB。

【原因3解决方案】

检查USB ADB驱动和虚拟串口驱动是否正常安装。

父主题： 常见故障处理


虚拟串口下载完成之后不能进行ADB下载

现象描述

BOOT_MODE点短接，连接USB，启动IDT，IDT完成虚拟串口bootloader下载后，不能切换到ADB下载，如图1所示。

图1 切换ADB下载失败

原因分析

1.fastboot.img有错误。

2.之前使用USB MAP映射的端口与当前使用的端口不一致。

3.USB驱动未安装，或者安装版本不正确。

4.终端设备硬件错误。

处理方法

【原因1解决方案】

更换正确的fastboot.img。

【原因2解决方案】

  1. 在Windows系统的“ 开始-->运行”中输入“regedit”打开注册表。
  2. 进入HKEY_LOCAL_MACHINE\SOFTWARE\Hisilicon\IDT\ENUMERATIONS，删除所有键值，重新使用USB MAP工具（实验室下载不使用USB MAP工具），重启IDT工具。

    ----结束

【原因3解决方案】

检查USB ADB驱动和虚拟串口驱动是否正常安装。

【原因4解决方案】

进行硬件检测修复。

父主题： 常见故障处理


ADB下载分区不存在或数据太大

现象描述

BOOT_MODE点短接，连接USB，启动IDT，IDT完成虚拟串口bootloader下载，切换到ADB下载，出现分区不存在，或者数据太大。

原因分析

1.fastboot.img版本与所要下载的镜像不匹配

处理方法

【原因1解决方案】

更换正确的fastboot.img。

父主题： 常见故障处理


错误列表

本章提供使用IDT工具下载失败时返回的错误类型查询。

表1 错误列表
错误号 | 错误描述
0 | 无错误
1 | 系统API调用错误
2 | 打开本地镜像文件失败
3 | 打开指定下载端口失败
4 | 向手机或单板发送数据失败
5 | 从下载端口接受反馈数据失败
6 | 等待虚拟串口响应超时
7 | 手机或单板对数据进行CRC校验失败
8 | 接收到一个从手机或单板返回的未知响应
9 | 手机或单板接收到的数据块无效
10 | 手机或单板接收到不完整数据块
11 | 手机或单板接收到一个不支持的命令
12 | 手机或单板接收到的数据块不符合要求
13 | 手机或单板接收到的文件信息数据块中的类型无效
14 | 手机或单板接收到的文件信息数据块中的长度错误
15 | 手机或单板接收到的文件信息数据块中的烧写地址错误
16 | 没有闪存
17 | 随机存储器异常
18 | 切换至下载模式失败
19 | 指示下载状态的LED灯未工作
20 | 擦除闪存数据失败
21 | 向闪存写入数据失败
22 | 从闪存读取数据失败
23 | 实际烧写的镜像个数与指示的个数不一致
24 | 进行cp下载时，向modem转换传递数据失败
25 | 手机或单板没有存储版本信息，不能进行版本比对
26 | 闪存异常
27 | 镜像文件ECC与手机闪存中的ECC不匹配
28 | USB端口打开失败
29 | 发送数据失败
30 | 内存溢出
31 | ONCHIPROM错误
32 | 镜像文件解析失败
33 | fastboot响应超时
父主题： 欢迎使用IDT映像下载工具 帮助


缩略语

I |  |
IDT | Image Download Tool | 镜像下载工具
父主题： 欢迎使用IDT映像下载工具 帮助